home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > performance & modifications

Reply
 
Thread Tools Display Modes
Old 02-03-2020, 05:40 PM   #1
maxitoman007
Board Member
 
maxitoman007's Avatar
 
Join Date: Feb 2017
Location: Calgary, Alberta, Canada
Question IPD Turbo Cam = Lower boost AFR?

I currently have an EBay T3/T4 turbo pushing ~25psi on my 87 Volvo 740 turbo. I have also installed browntops for added fuel, but even after “tuning” full lean using the MAF adjustment screw, I am still in 10s up top based on my wideband. I recently purchased an IPD Turbo cam and I’m wondering if it could help with my rich AFR issue under boost. Could retarding the timing to move the power band up help even more (I do have an adjustable cam gear installed)?

Anybody have any experience with this?
maxitoman007 is offline   Reply With Quote
Old 02-03-2020, 05:48 PM   #2
dl242gt
My car is fun hp club
 
dl242gt's Avatar
 
Join Date: Jun 2002
Location: S NJ, a suburb of Phila.
Default

Maybe you aren't burning the fuel up top? What plug gap are you running? Have you done anything to have a bit more spark energy? It will be rich if you can't burn what is getting sprayed in there. 25psi should have something upgraded to light that fire.

Last edited by dl242gt; 02-03-2020 at 05:49 PM.. Reason: spelling
dl242gt is offline   Reply With Quote
Old 02-03-2020, 07:51 PM   #3
maxitoman007
Board Member
 
maxitoman007's Avatar
 
Join Date: Feb 2017
Location: Calgary, Alberta, Canada
Default

Quote:
Originally Posted by dl242gt View Post
Maybe you aren't burning the fuel up top? What plug gap are you running? Have you done anything to have a bit more spark energy? It will be rich if you can't burn what is getting sprayed in there. 25psi should have something upgraded to light that fire.
Just purchased an MSD-6a so hopefully that helps!
maxitoman007 is offline   Reply With Quote
Old 02-03-2020, 08:48 PM   #4
James M
Bored member
 
James M's Avatar
 
Join Date: May 2017
Location: Chico, CA
Default

Is the wideband placed far enough back in the down pipe and calibrated well?

Atleast its rich and not lean, and you pay attention to your wide-band
20200104-224609
James M is offline   Reply With Quote
Old 02-03-2020, 08:57 PM   #5
VB242
Beep beep zip tang
 
VB242's Avatar
 
Join Date: Sep 2011
Location: The Right Coast
Default

What's the condition of your exhaust system? I could only run 15psi with brown tops on lh2.2.
__________________
Deviant Volvo collector/cat herder.
VB242 is offline   Reply With Quote
Old 02-03-2020, 08:57 PM   #6
benflynn
bigpimpin740t@yahoo.com
 
benflynn's Avatar
 
Join Date: Mar 2005
Location: Birmingham Al
Default

Dubious it’s so rich at 25psi and browntops, but it’s been a decade since I’ve seen a 530 and Tcam
__________________
85 744 Turbo F+T big valved531, stg5 cam, msns, m47, sways, bills, 53mm t3/t4 9lb flywheel, dual 044s, 80lbs, npr og
benflynn is offline   Reply With Quote
Old 02-03-2020, 09:00 PM   #7
maxitoman007
Board Member
 
maxitoman007's Avatar
 
Join Date: Feb 2017
Location: Calgary, Alberta, Canada
Default

Quote:
Originally Posted by James M View Post
Is the wideband placed far enough back in the down pipe and calibrated well?

Atleast its rich and not lean, and you pay attention to your wide-band
20200104-224609
To the best of my knowledge it is calibrated correctly. Reads around 14.4 at idle.

Last edited by maxitoman007; 02-03-2020 at 09:41 PM..
maxitoman007 is offline   Reply With Quote
Old 02-03-2020, 09:05 PM   #8
maxitoman007
Board Member
 
maxitoman007's Avatar
 
Join Date: Feb 2017
Location: Calgary, Alberta, Canada
Default

Quote:
Originally Posted by VB242 View Post
What's the condition of your exhaust system? I could only run 15psi with brown tops on lh2.2.
My exhaust is a hood dump. 2.5 inch but only about 2ft long
maxitoman007 is offline   Reply With Quote
Old 02-03-2020, 09:48 PM   #9
James M
Bored member
 
James M's Avatar
 
Join Date: May 2017
Location: Chico, CA
Default

Quote:
Originally Posted by maxitoman007 View Post
My exhaust is a hood dump. 2.5 inch but only about 2ft long
I was running an up-pipe without a hood for a little, never got the wide band to work when It was on but it doesn't help stable AFR.
James M is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:22 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.